Apache – CVE-2021-42013


Kayran has detected that the version of Apache HTTP Server being used is vulnerable to a Path Traversal attack (CWE-22).
The CVE-2021-42013 exist due to the fact that a fix for a previous problem, CVE-2021-41773 was insufficient.

An attacker could use a Path Traversal attack to map URLs to files outside the directories that are configured by Alias-like directives.
If files outside of these directories are not protected by the usual default configuration “require all denied”, these requests can succeed.
Remote code execution is also possible if CGI scripts are also enabled for these aliased pathes.

Remote attackers could abuse this Information Disclosure to obtain potentially sensitive information, assisting them in initiating attacks.


It was found that CVE-2021-42013 only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions, so you can downgrade if this is your wish.

To properly fix this issue, upgrade the version of Apache HTTP Server being used to 2.4.51 or higher.




< Return to all Vulnerabilities

HAR Files

In this article, I’ll talk and explain about HAR Files, so if you don’t know what they are, or, what do we use them for,

Read More »

The Cloud

I’m pretty sure there isn’t a single adult in the world who hasn’t at least heard of The Cloud. Explaining “The Cloud” in 2022 may

Read More »