jQuery – CVE-2020-11022


Kayran has detected that the jQuery version being used is vulnerable to Execute Code Cross Site Scripting.
That means that passing HTML from untrusted sources is enabled and could lead to undesirable results.

This vulnerability means, that HTML being passed from untrusted sources could execute untrusted code. Even if the HTML is being sanitized using “.html()”, “.append()” and others the untrusted code could potentially be executed.
This allows an attacker to modify some system files or information. Yet, the attacker does not have control over what can be modified, or very limited in terms of possibilities.


CVSS Version 3.x – 6.1 Medium


Upgrade the version of the jquery you use.
Since it exists only in versions 1.2 through 3.5.0, make sure you upgrade to version 3.5.0 or higher.




< Return to all Vulnerabilities

Using VPN

What is a VPN? Why should someone be using VPN? Which Problems does is solve? and what is the advantages and disadvantages of it? Let’s

Read More »

Explaining API

We’ve talked about API’s Vulnerability in here, but i feel like there’s much more to talk about and explain since this is a big and

Read More »

Bug Bounties

As pirates, we all love plundering, we all love raiding, but mostly, we all love bounties, especially Bug Bounties. Let’s talk about it. Bug Bounties

Read More »